Starta programmering med IP-gränssnitt - LÖST

Hanterar frågor kring ETS programering
Lillmicke
Junior Medlem
Junior Medlem
Inlägg: 6
Blev medlem: 14 nov 2014, 00:23
Kontakt:

Starta programmering med IP-gränssnitt - LÖST

Oläst inläggav Lillmicke » 29 nov 2014, 21:13

LÖSNING: Monterade extern drossel. Dock initierades allt med USB-gränssnitt.

Hej! Jag försöker få igång programmeringen i mitt KNX via ett ABB IP-gränssnitt, men det vill sig inte riktigt.
Modulen jag använder mig utav är ABB IPS/S 2.1.
ETS 4.1.6 (även provat ETS5 demo).

När jag ansluter nätverkskabeln mellan dator och modul upptäcks modulen i ETS. Sätter individuella adressen till 1.1.244 och testar kommunikationen via testknappen utan problem (får ett OK).
Går över i projektet och vill programmera IP-gränssnittets individuella adress (som är 1.1.11). Programmeringsdialogen öppnas till höger i bild och den ber mig att trycka in programmeringsknappen (vilket jag gör och en röd diod tänds på modulen), men efter detta händer nada. Den ändrar aldrig texten (tryck in programmeringsknappen) och tar sig inte vidare här ifrån. Ingen annan enhet i systemet går att programmera heller, men det antar jag beror på att själva gränssnittet inte är programmerat än?

Provade att ansluta modulen via en router, men något annat än att lampan på routern tänds upp, händer inte. Går jag in i routern finns endast min dator ansluten på dess lista över anslutna enheter.

Jättetacksam för någon form av hjälp (annan än "köp ett USB-gränssnitt, eller en IP-router"). Skulle vara fint att få igång det med denna.
Senast redigerad av Lillmicke 16 dec 2014, 09:30, redigerad totalt 1 gång.

weavex
Medlem
Medlem
Inlägg: 73
Blev medlem: 09 apr 2013, 22:10
Kontakt:

Re: Starta programmering med IP-gränssnitt - problem

Oläst inläggav weavex » 30 nov 2014, 00:27

Inte för att det hjälper. Men jag tror inte det finns någon lösning. Detta är en begränsning med IP-interface.

EDIT: Du bör dock fortfarande kunna använda det fastän du inte programmerar det. Som standard är den fysiska adressen 15.15.100. Och den bör få en IP-adress av din router via DHCP.
Senast redigerad av weavex 01 jan 1970, 01:00, redigerad totalt 0 gånger.
Anledning: ""

Videonisse
Betrodd medlem
Betrodd medlem
Inlägg: 339
Blev medlem: 30 aug 2011, 23:39
Kontakt:

Re: Starta programmering med IP-gränssnitt - problem

Oläst inläggav Videonisse » 01 dec 2014, 17:51

IP-gränssnitt täcker ju behovet för nästan alla situationer för privatlösningar och har tom vissa fördelar gentemot en router (tex busmonitor och ack för IP-kommunikationen).

Försök att först bara använda defaultvärden, tex 15.15.x linje om det står i dokumentationen. När det snurrar så kan du alltid ändra.
Senast redigerad av Videonisse 01 jan 1970, 01:00, redigerad totalt 0 gånger.
Anledning: ""
Bygger ut & renoverar villa från 1943, 8 rum+kök+2 WC/dusch. KNX i utbyggnaden, utökar när renoveringen fortskrider. Bel.plan från ljusdesigner för hela huset, ca 100 downlights totalt+övriga fasta armaturer+lamputtag. Styrning via Dali eller DMX.

rightnow
Medlem
Medlem
Inlägg: 71
Blev medlem: 08 jan 2014, 18:45
Kontakt:

Re: Starta programmering med IP-gränssnitt - problem

Oläst inläggav rightnow » 03 dec 2014, 19:55

Vad har du för inställningar på gränssnittet i nätverksinställningarna?
Senast redigerad av rightnow 01 jan 1970, 01:00, redigerad totalt 0 gånger.
Anledning: ""

Lillmicke
Junior Medlem
Junior Medlem
Inlägg: 6
Blev medlem: 14 nov 2014, 00:23
Kontakt:

Re: Starta programmering med IP-gränssnitt - problem

Oläst inläggav Lillmicke » 05 dec 2014, 08:03

Hej!
Jag har fått en adress från routern, men ingen skillnad. Jag har kört likväl automatiserad som fast ip-adress, fast utan skillnad på resultat.

Har provat med standardvärden på gränssnittet (som skall vara 1.1.255).

Köpte ett ABB USB/S1.1 för att enkelt få bukt på problemet, men jag hade ingen större framgång med detta. Det är faktiskt samma bekymmer. Den står och tuggar och vill att jag trycker in programmeringsknappen. När man väl löst det grundläggande problemet så fungerar nog ip-gränssnittet också. Jag förstår dock inte vad det kan vara? Har läst på internet att folk haft liknande problem och de har fått någon enstaka fil eller insticksmodul från KNX för att lösa det.

Känner mig hopplös i detta.

Tack för er hjälp hittills!

/Micke
Senast redigerad av Lillmicke 01 jan 1970, 01:00, redigerad totalt 0 gånger.
Anledning: ""

rightnow
Medlem
Medlem
Inlägg: 71
Blev medlem: 08 jan 2014, 18:45
Kontakt:

Re: Starta programmering med IP-gränssnitt - problem

Oläst inläggav rightnow » 05 dec 2014, 15:29

Jag hade samma problem, men det visade sig vara fel inställningar i konfigureringen av gränssnittet.

1.1.255 är ju bara en interna adressen. Visa ett screenshot på övriga inställningar på gränssnittet.

Och vilket IP har gränssnitet från från routern via DHCP?
Senast redigerad av rightnow 01 jan 1970, 01:00, redigerad totalt 0 gånger.
Anledning: ""

Lillmicke
Junior Medlem
Junior Medlem
Inlägg: 6
Blev medlem: 14 nov 2014, 00:23
Kontakt:

Re: Starta programmering med IP-gränssnitt - problem

Oläst inläggav Lillmicke » 05 dec 2014, 21:25

Den får 192.168.0.3 av routern.
Denna adress har jag testat att sätta som fast adress i inställningarna för gränssnittet, men ingen skillnad.

Ipconfigrouter.jpg

Router.jpg


Här är även ett par bilder utan router:
discovered.jpg

parametrar.jpg


Linjeinställningar:
Linjeconfig.jpg


/ Micke
Senast redigerad av Lillmicke 01 jan 1970, 01:00, redigerad totalt 0 gånger.
Anledning: ""

rightnow
Medlem
Medlem
Inlägg: 71
Blev medlem: 08 jan 2014, 18:45
Kontakt:

Re: Starta programmering med IP-gränssnitt - problem

Oläst inläggav rightnow » 05 dec 2014, 23:36

Du har inte selectat interfacet på bilderna. Är det så eller va det bara nu?

Kör med router som du har först. Men selecta det. Sen ta edit på den o visa dom inställningarna.
Sätta fast ip kan du inte göra förän du lyckats programmera den. O det är ju det som inte går än :)

För att förtydliga :

Bild nr 2 med router. Tryck på interfacet, välj select. Då ska den komma upp som aktivt. Då tänds även edit knappen upp där nere, så kan du se lite fler inställningar. Under de inställningarna ska du inte välja routing.
Senast redigerad av rightnow 01 jan 1970, 01:00, redigerad totalt 0 gånger.
Anledning: ""

Lillmicke
Junior Medlem
Junior Medlem
Inlägg: 6
Blev medlem: 14 nov 2014, 00:23
Kontakt:

Re: Starta programmering med IP-gränssnitt - problem

Oläst inläggav Lillmicke » 06 dec 2014, 20:13

Hej!

Jag hade inte valt in interfacet på bilden endast. Har alltid haft det invalt när jag försökt programmera enheterna.

Såhär ser det ut under inställningarna:
IPedit.jpg


Här är ett par bilder med USB-gränssnittet:
usb-program.jpg

usb-select.jpg


/Micke
Senast redigerad av Lillmicke 01 jan 1970, 01:00, redigerad totalt 0 gånger.
Anledning: ""

rightnow
Medlem
Medlem
Inlägg: 71
Blev medlem: 08 jan 2014, 18:45
Kontakt:

Re: Starta programmering med IP-gränssnitt - problem

Oläst inläggav rightnow » 06 dec 2014, 20:59

Hmm, nej nu jäklar! Sur jag blir att det inte funkar.

Testa sätt individuel address till: 15.15.100 under Local settings på interfacet.
Kunde du pinga 192.168.0.3? Visst såg du att den fick det IP:t av DHCP:n i din router?
Senast redigerad av rightnow 01 jan 1970, 01:00, redigerad totalt 0 gånger.
Anledning: ""


Återgå till "Programering / ETS"

Vilka är online

Användare som besöker denna kategori: 3 och 0 gäster